AnsweredAssumed Answered

"obtaining IP address" issue on Nexus 4

Question asked by ambient13 on May 13, 2014
Latest reply on Jun 2, 2014 by [shaw]ali

Hi there,

 

On my N4, updated to latest version of Android KitKat 4.4.2, it often takes a significant amount of time (2-3 min) to connect to any shaw go WiFi hotspot unfortunately. I suspect that this is an issue with the DHCP handling, but the weird thing is that this never used to happen before.

 

Also, my phone connects to other WiFi hotspots just fine.

 

My laptop obtains an IP address from shaw go faster than my phone but connecting from my laptop for internet access isn't as ideally fast as it would be there either.

 

So far, I have tried forgetting all the saved networks, rebooting my phone, and factory resetting from scratch. Nothing so far has served as a permanent fix.

 

I should note that it sometimes connects right away so I am not sure if it is an access point issue on shaw's end with the firmware perhaps. The fact that this happens at every shaw hotspot also leads me to think that such a cause is plausible, though I cannot be certain. All I know for sure is that it may otherwise be a problem with stock android 4.4.2 communicating with shaw go hotspots, or a specific problem with the way my settings are configured.

 

I am eagerly awaiting an update to 4.4.3 to see if that helps. Until then, it's hard for me to say whether or not this problem is with my specific phone, or current android software/drivers/kernel, or shaw's routers/router firmware.

 

If someone with the same version of Android can test, please let me know how it is!

Outcomes