generalknowledge

Hitron Modem Wired Connection Issues

Discussion created by generalknowledge on Aug 27, 2018

Have had a Shaw Hitron modem/router for several months now and have had ongoing issues with the wired connections.  Every single wired device (Sony Bravia android smart TV, Xbox One, MacBook, Apple TV 4k) has had the same connectivity issue:  the modem’s wifi works fine but booting  up a device will regularly be met with an inability to connect to the internet via wired Ethernet.

 

  I have to reboot (unplug, replug) the modem to get back online. This can take up to 10 minutes each time, up to twice a day.  Now I find I’m having to re-sign in to some apps every time it happens.

 

its extremely frustrating and have changed Hitron modems at last 3 times, the last time a tech came in and noted my TV was broadcasting its own wifi signal.  I shut down everything on the TV that could have possibly been interfering wi5 the modem to NO AVAIL.  It seems to work properly for a stretch and then goes right back to being finicky.

 

Am getting a Cisco router this weekend, to be installed by a Shaw technician (they don’t keep this modem at their storefronts nor will they mail them to you direct, nor will they explain why they have to do it this way.) when I ask whether other customers have had problems with this router, the Shaw support person won’t tell me yes or no.  They just don’t answer the question. 

 

HAS ANYONE ELSE HAD WIRED CONNECTIVITY ISSUES WITH THE HITRON MODEM?  Not wifi, WIRED.  

 

This is is my last attempt to get this issue fixed then I’m moving my business elsewhere.  

Have used Shaw for 20 years and this issue is going to break me.

Outcomes