AnsweredAssumed Answered

Why am I getting latency issues with Blizzard Games?

Question asked by 0mirage on Oct 4, 2018
Latest reply on Oct 5, 2018 by 0mirage

Hello everyone, I've been having trouble with blizzard games for the better part of about 2 years and have been unable to play Overwatch properly. So between Puma 6 issues and what I believe to be Blizzard server issues Its been far too long and I'd like to be able to isolate the problem and figure out the source once and for all. 

 

A Summary of the problem: In overwatch I get double animations and ability delay. I stopped playing it for about 6 months only to discover the problem was still there, I also tested it with a Telus connection and it had the same ability delay. I more recently tried World of Warcraft and to my surprise it had identical problems, where using abilities had significant delay. I'm not sure this is exclusive to blizzard games but it seems to be, as I can pretty comfortably play other games without feeling hindered.

 

I've ran WinMTRs I'd like to show, as well as 'looking glass' tests from blizzard's end that I was hoping I could get a second opinion on.

 

Looking Glass Tests:

 

MTR:
Start: Fri Oct 5 00:32:22 2018 Blizzard 1.|-- Blizzard 0.0% 10 0.3 0.3 0.2 0.4 0.0
2.|-- 37.244.23.130 0.0% 10 0.4 0.4 0.4 0.6 0.0
3.|-- 24.105.62.146 0.0% 10 1.4 1.2 1.1 1.4 0.0
4.|-- 137.221.66.12 0.0% 10 2.4 2.4 2.2 2.5 0.0
5.|-- 137.221.69.72 0.0% 10 2.3 5.9 2.2 21.0 7.7
6.|-- 137.221.69.34 0.0% 10 11.4 4.2 1.6 11.4 3.5
7.|-- rt1ec-equinix.il.shawcable.net 0.0% 10 2.3 2.5 2.3 2.8 0.0
8.|-- rc3sc-be25-1.wp.shawcable.net 0.0% 10 17.3 17.2 17.0 17.5 0.0
9.|-- 66.163.70.78 0.0% 10 51.0 51.3 51.0 51.5 0.0
10.|-- dx6lo-lag0.ed.shawcable.net 0.0% 10 51.8 98.4 51.7 518.2 147.5
11.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0


05/10/2018 00:32:22 UTC
--------------------

MTR:
Start: Fri Oct 5 00:32:22 2018 Blizzard 1.|-- Blizzard 0.0% 10 0.3 0.3 0.2 0.4 0.0
2.|-- 37.244.22.3 0.0% 10 0.5 0.5 0.5 0.6 0.0
3.|-- 24.105.30.148 0.0% 10 0.8 1.0 0.8 1.2 0.0
4.|-- 137.221.66.0 0.0% 10 1.4 1.4 1.3 1.6 0.0
5.|-- 137.221.68.70 0.0% 10 11.2 9.8 8.4 17.4 2.8
6.|-- 137.221.65.7 0.0% 10 8.4 11.2 8.3 36.0 8.7
7.|-- 137.221.70.32 0.0% 10 8.2 8.3 8.2 8.4 0.0
8.|-- rt0sj-equinix.cl.shawcable.net 0.0% 10 10.4 10.3 8.8 11.9 0.9
9.|-- rc4sj-tge0-0-0-0.cl.shawcable.net 0.0% 10 10.7 11.1 9.4 12.8 0.9
10.|-- rc2wt-be60.wa.shawcable.net 0.0% 10 28.1 27.9 27.0 29.3 0.3
11.|-- rc3no-be100.cg.shawcable.net 0.0% 10 42.3 42.3 41.9 43.5 0.0
12.|-- rc1we-be6.ed.shawcable.net 0.0% 10 46.0 46.5 45.8 49.2 0.9
13.|-- dx6lo-lag1.ed.shawcable.net 0.0% 10 46.3 65.6 46.3 238.6 60.8
14.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0


05/10/2018 00:32:22 UTC
--------------------

 

 

MTR:
Start: Fri Oct 5 01:28:22 2018 Blizzard 1.|-- Blizzard 0.0% 10 0.4 0.3 0.3 0.4 0.0
2.|-- 37.244.23.2 0.0% 10 0.6 0.6 0.5 0.8 0.0
3.|-- 24.105.62.146 0.0% 10 2.2 1.4 0.8 2.2 0.0
4.|-- 137.221.66.8 0.0% 10 2.0 2.1 1.9 2.2 0.0
5.|-- 137.221.69.66 0.0% 10 2.0 3.0 1.9 12.2 3.2
6.|-- 137.221.69.32 0.0% 10 1.8 3.6 1.7 17.4 4.8
7.|-- rt1ec-equinix.il.shawcable.net 0.0% 10 1.9 2.0 1.8 2.2 0.0
8.|-- rc3sc-be25-1.wp.shawcable.net 0.0% 10 19.5 18.0 17.4 19.5 0.5
9.|-- 66.163.70.78 0.0% 10 50.5 50.7 50.5 50.8 0.0
10.|-- dx6lo-lag0.ed.shawcable.net 0.0% 10 51.4 92.9 51.1 468.1 131.8
11.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0


05/10/2018 01:28:22 UTC
--------------------

MTR:
Start: Fri Oct 5 01:28:22 2018 Blizzard 1.|-- Blizzard 0.0% 10 0.2 0.3 0.2 0.5 0.0
2.|-- 37.244.22.3 0.0% 10 0.5 0.6 0.5 0.7 0.0
3.|-- 24.105.30.148 0.0% 10 1.2 1.1 1.0 1.3 0.0
4.|-- 137.221.66.0 0.0% 10 1.5 1.6 1.4 1.7 0.0
5.|-- 137.221.68.70 0.0% 10 8.5 14.0 8.4 63.1 17.2
6.|-- 137.221.65.7 0.0% 10 21.2 9.8 8.4 21.2 4.0
7.|-- 137.221.70.32 0.0% 10 8.3 8.4 8.2 9.1 0.0
8.|-- rt0sj-equinix.cl.shawcable.net 0.0% 10 11.1 10.1 8.8 12.1 1.2
9.|-- rc4sj-tge0-0-0-0.cl.shawcable.net 0.0% 10 13.0 10.6 9.0 13.0 1.2
10.|-- rc2wt-be60.wa.shawcable.net 0.0% 10 27.1 27.1 26.9 27.3 0.0
11.|-- rc3no-be100.cg.shawcable.net 0.0% 10 43.7 42.8 41.9 44.3 0.5
12.|-- rc1we-be6.ed.shawcable.net 0.0% 10 46.0 46.1 45.8 46.4 0.0
13.|-- dx6lo-lag1.ed.shawcable.net 0.0% 10 46.3 58.0 46.3 162.4 36.7
14.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0


05/10/2018 01:28:21 UTC
--------------------

 

 

Shows 468ms on a shaw server:

10.|-- dx6lo-lag0.ed.shawcable.net 0.0% 10 51.4 92.9 51.1 468.1 131.8

 

Shows 162.4ms on a shaw server:

13.|-- dx6lo-lag1.ed.shawcable.net 0.0% 10 46.3 58.0 46.3 162.4 36.7

 

Shows 238.6 ping on a shaw server:

13.|-- dx6lo-lag1.ed.shawcable.net 0.0% 10 46.3 65.6 46.3 238.6 60.8

 

 

Now here's what I don't understand...through the looking glass testing it points to shaw servers having high ping, but I don't seem to have issues with other games. And what doesn't make sense is if I run a regular WinMTR test on my end to blizzard servers I get very different results:

 

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| 192.168.1.1 - 0 | 178 | 178 | 1 | 3 | 14 | 2 |
| 96.52.128.1 - 0 | 178 | 178 | 9 | 27 | 657 | 14 |
| 64.59.186.165 - 0 | 178 | 178 | 11 | 19 | 46 | 17 |
| rc3no-be6.cg.shawcable.net - 0 | 178 | 178 | 14 | 23 | 52 | 18 |
| rc2wt-be100.wa.shawcable.net - 0 | 178 | 178 | 29 | 38 | 60 | 35 |
| rc1wt-be18-1.wa.shawcable.net - 0 | 178 | 178 | 30 | 40 | 68 | 36 |
| eqix-se2.blizzardentertainment.com - 0 | 178 | 178 | 30 | 38 | 57 | 32 |
| ae1-br01-eqse2.as57976.net - 0 | 178 | 178 | 55 | 64 | 97 | 62 |
| xe-0-0-0-1-br01-eqsv5.as57976.net - 0 | 178 | 178 | 55 | 64 | 99 | 65 |
| xe-0-0-1-1-br02-eqla1.as57976.net - 0 | 178 | 178 | 54 | 66 | 186 | 60 |
| be2-pe01-eqla1.as57976.net - 0 | 178 | 178 | 54 | 64 | 91 | 63 |
| lax-eqla1-ia-bons-01.as57976.net - 0 | 178 | 178 | 55 | 62 | 84 | 65 |
| 37.244.22.3 - 0 | 178 | 178 | 53 | 81 | 865 | 59 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

 

 

And for a baseline a comparable to google.ca:

 

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| 192.168.1.1 - 0 | 30 | 30 | 1 | 3 | 12 | 2 |
| 96.52.128.1 - 0 | 30 | 30 | 10 | 27 | 333 | 16 |
| 64.59.186.165 - 0 | 30 | 30 | 15 | 20 | 41 | 17 |
| rc3no-be6.cg.shawcable.net - 0 | 30 | 30 | 18 | 24 | 42 | 21 |
| rc2wt-be100.wa.shawcable.net - 0 | 30 | 30 | 30 | 39 | 56 | 36 |
| 72.14.242.90 - 0 | 30 | 30 | 33 | 39 | 49 | 36 |
| No response from host - 100 | 6 | 0 | 0 | 0 | 0 | 0 |
| 74.125.253.66 - 0 | 30 | 30 | 29 | 37 | 43 | 32 |
| 108.170.245.123 - 0 | 30 | 30 | 36 | 40 | 59 | 37 |
| 209.85.248.159 - 0 | 30 | 30 | 33 | 45 | 67 | 33 |
| 209.85.241.42 - 0 | 30 | 30 | 57 | 64 | 71 | 66 |
| 209.85.250.145 - 0 | 30 | 30 | 59 | 65 | 76 | 64 |
| 108.170.243.174 - 0 | 30 | 30 | 58 | 67 | 78 | 63 |
| 216.239.47.87 - 0 | 30 | 30 | 60 | 66 | 76 | 63 |
| ord38s18-in-f3.1e100.net - 0 | 30 | 30 | 55 | 62 | 70 | 58 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

 

 

Is there anything that sticks out in the testing? I'm looking for any suggestions at this point. Thanks in advance!

 

EDIT: Forgot to mention I'm on the 300 plan with an XB6.

Outcomes