jadonprez

4+ years later, STILL unable to stream to Twitch.... hello?

Discussion created by jadonprez on Oct 31, 2018
Latest reply on Nov 10, 2018 by jadonprez

I no longer have the patience for any of this. I've been paying for, what SHOULD be more than good enough internet for 4-5 years now, in order to live stream to Twitch.tv and yet STILL the same issue is alive and well.

 

Yes, I've called about the issue, literally dozens of times over the years. I've had at LEAST half a dozen different technicians (including a "senior" technician) come to the house to evaluate the issue, some of which have even been here more than once. The last few times I've had someone come here, I've been told: "everything has already been checked multiple times and everything is basically brand new & there are no issues on your end. I will pass the issue on", etc. Yet, nothing ever happens from there. Wonderful, right?

 

I've gone through over a dozen modems, as the technicians insist on replacing the already brand new one that I had.... every single time they come here. So CLEARLY there is not an issue on my end whatsoever. I've been told that I might need to "upgrade" my plan multiple times, which I actually ended up doing (went from the 75/7.5 package to 150/15 package) just to see if MAYBE it someway somehow would actually help. Boy was I ever wrong. It only takes about 2.5 to 3.0 mbps upload to stream to Twitch with the settings that I use.... yet my bitrate never fails to randomly plummet to literally 0 whenever it likes, and for as long as it likes.

 

Over the last 4 to 5 years, I HAVE gone short periods (a few weeks at a time AT MOST) with no issues whatsoever. But also have gone several months straight with my upload speed apparently plummeting each and every day without fail. I don't think it's even the speed that's dropping, because speed tests are ALWAYS perfectly fine. It's just when I actually try to stream to twitch that it completely fails to do it's job.

 

Streaming to Twitch has been a major part of my income over the year of 2018, yet over the last two months I literally cannot even stream for 30 seconds without my bitrate absolutely plummeting. Completely unacceptable.

 

I've seen MANY posts about this over the years on these forums, and it looks like it's an issue that just isn't being resolved. What is the problem here, Shaw? I'm just being completely ripped off at this point. Clearly there is some sort of issue with Shaw reaching the servers to Twitch or SOMETHING. This has been a known issue for years, and yet still it still hasn't gotten any better.

 

Highly considering switching to the other ISP in my city asap, as they are currently rolling out their Fibre internet as we speak. So this is the last chance that I am willing to give Shaw. I'm beyond tired of dealing with this. I need to hear something different for once. I've tried everything a hundred times over. ANY sort of answers would be lovely.

Outcomes