AnsweredAssumed Answered

Problem with one device not getting an IP address

Question asked by forgottenhill on Jun 26, 2013
Latest reply on Jun 26, 2013 by kevinds

Hi,

 

My Shaw modem is connected to a D-Link 655 router. Computers, iPads, and telephones all automatically get an IP address wihout any problem. One device, however, does not. The device is a Moneris S80 credit card machine that is connected directly to the router. For some reason, it does not seem to get an ip and defaults to the phone line. Moneris technical support could not figure out what is wrong and replaced the machine, but with the same result. D-Link could not figure it out either since everything else works normally. The Moneris S80 uses port 443 to communicate, and that port is open on the router. However, when the machine tries to obtain an IP address, it times out. This second S80 does the same thing. Moneris Tech support told me to contact Shaw and ensure that they allow traffic through that port... I called (on hold for an hour) only to be told that Shaw has nothing to do with it. I'm at a loss to understand why this is happening.

To date we have tried the following:

  • Exchanged CAT 5 cables
  • Exchanged the credit card reader
  • Rebooted everything countless times
  • Verified that the router is set correctly (it is)

 

I hope someone on this forum can give a suggestion as to what could be wrong, and how to correct it.

 

Thanks.

Outcomes