AnsweredAssumed Answered

Yet another problem with the Movie Central Go app...again

Question asked by techkat on Aug 28, 2013
Latest reply on Aug 28, 2013 by [shaw]ali

Well, I've managed to successfully watch 2 shows, this thing usually doesn't work for some reason or other.

 

Today is a new problem.  I attempted to watch a show and was given some sort of error message of an unknown nature.  Then I was given a message indicating I need to be a subscriber to Movie Central, which I already am and have been for quite a while now.   I thought I would try logging out and logging back in.  Mistake.  Now the app won't log me back in.  I am told "We're sorry, our serves appear to not be responding.  Please try logging in again later."  I logged onto my account on my windows laptop and tried changing my password.  That had worked in the past when (the first time I tried this app) the app would not log me in.  Well, that didn't work this time.

 

I am in western Canada.  I am a satellite internet subscriber but I just checked my geo location and it does have my IP being in the west.

 

I am attempting to log in with my Shaw Direct account number and password.

 

And I've uninstalled and reinstalled.  Location services is enabled.

 

Is it time to simply give up with this app? 

Outcomes